$re = '/<body[^>]*>/';
$str = '<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02" style="width: 100%;">
<body class="s-category-linux" style="background-color: red;">
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10" style="width: 100%;"><div id="wrapper"><div id="header">';
$subst = "$0<mynewtag>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;