use strict;
my $str = '<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02" style="width: 100%;">
<body class="s-category-linux" style="background-color: red;">
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10" style="width: 100%;"><div id="wrapper"><div id="header">';
my $regex = qr/<body[^>]*>/p;
my $subst = '$0<mynewtag>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";