using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<body[^>]*>";
string substitution = @"$0<mynewtag>";
string input = @"<body class=""wordpress y2015 m10 d23 h12 single s-y2010 s-m02"" style=""width: 100%;"">
<body class=""s-category-linux"" style=""background-color: red;"">
<body class=""wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10"" style=""width: 100%;""><div id=""wrapper""><div id=""header"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}