import Foundation
let pattern = #"<body[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02" style="width: 100%;">
<body class="s-category-linux" style="background-color: red;">
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10" style="width: 100%;"><div id="wrapper"><div id="header">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0<mynewtag>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)