# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<body[^>]*>"
test_str = ("<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02\" style=\"width: 100%;\">\n"
"<body class=\"s-category-linux\" style=\"background-color: red;\">\n"
"<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10\" style=\"width: 100%;\"><div id=\"wrapper\"><div id=\"header\">")
subst = "$0<mynewtag>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.