using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<? #([a-zA-Z0-9-]+).+?>";
string input = @"hola amigo #nombre1
<div>
<input # style=""hola"" #nombre-incidencia type=""text""/>
<div *ngFor="" #nombre2 of list"">{{nombre}}</div>
</div>
<input #nombre3 type=""submit""/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type=""submit""/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}