// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<? #([a-zA-Z0-9-]+).+?>").unwrap();
let string = "hola amigo #nombre1
<div>
<input # style=\"hola\" #nombre-incidencia type=\"text\"/>
<div *ngFor=\" #nombre2 of list\">{{nombre}}</div>
</div>
<input #nombre3 type=\"submit\"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type=\"submit\"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}