import re
regex = re.compile(r"<? #([a-zA-Z0-9-]+).+?>")
test_str = ("hola amigo #nombre1\n"
"<div>\n"
" <input # style=\"hola\" #nombre-incidencia type=\"text\"/>\n"
" <div *ngFor=\" #nombre2 of list\">{{nombre}}</div>\n"
"</div>\n"
"<input #nombre3 type=\"submit\"/>\n"
"<div #nombre4>Este es tu #nombreno</div>\n"
"<span#nombre5>Tu nombre</span>\n\n"
"<input #nombre6 type=\"submit\"/>\n"
"<div #nombre7>Este es tu #nombrenooo</div>\n"
"<span#nombre8>Tu nombre</span>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")