import Foundation
let pattern = ##"<? #([a-zA-Z0-9-]+).+?>"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
hola amigo #nombre1
<div>
<input # style="hola" #nombre-incidencia type="text"/>
<div *ngFor=" #nombre2 of list">{{nombre}}</div>
</div>
<input #nombre3 type="submit"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type="submit"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)