import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<? #([a-zA-Z0-9-]+).+?>";
final String string = "hola amigo #nombre1\n"
+ "<div>\n"
+ " <input # style=\"hola\" #nombre-incidencia type=\"text\"/>\n"
+ " <div *ngFor=\" #nombre2 of list\">{{nombre}}</div>\n"
+ "</div>\n"
+ "<input #nombre3 type=\"submit\"/>\n"
+ "<div #nombre4>Este es tu #nombreno</div>\n"
+ "<span#nombre5>Tu nombre</span>\n\n"
+ "<input #nombre6 type=\"submit\"/>\n"
+ "<div #nombre7>Este es tu #nombrenooo</div>\n"
+ "<span#nombre8>Tu nombre</span>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}