const regex = /<? #([a-zA-Z0-9-]+).+?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<? #([a-zA-Z0-9-]+).+?>', 'g')
const str = `hola amigo #nombre1
<div>
<input # style="hola" #nombre-incidencia type="text"/>
<div *ngFor=" #nombre2 of list">{{nombre}}</div>
</div>
<input #nombre3 type="submit"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type="submit"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}