# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d\.).+\d\s(\w+)\s:/$1$2/gm;t' <<< "GSM NWS\TOP N Pool 1\1. TOP N Pool 1 Rank :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BCCH :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BSIC :
"