$re = '/(\d\.).+\d\s(\w+)\s:/m';
$str = 'GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;