const regex = /(\d\.).+\d\s(\w+)\s:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\.).+\\d\\s(\\w+)\\s:', 'gm')
const str = `GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);