import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\.).+\\d\\s(\\w+)\\s:";
final String string = "GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :\n"
+ "GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :\n"
+ "GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}