re = /(\d\.).+\d\s(\w+)\s:/m
str = 'GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result