import Foundation
let pattern = #"(\d\.).+\d\s(\w+)\s:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 Rank :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BCCH :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BSIC :
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)