using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\.).+\d\s(\w+)\s:";
string substitution = @"$1$2";
string input = @"GSM NWS\TOP N Pool 1\1. TOP N Pool 1 Rank :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BCCH :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BSIC :
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}