package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\.).+\d\s(\w+)\s:`)
var str = `GSM NWS\TOP N Pool 1\1. TOP N Pool 1 Rank :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BCCH :
GSM NWS\TOP N Pool 1\1. TOP N Pool 1 BSIC :
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}