// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d\.).+\d\s(\w+)\s:").unwrap();
let string = "GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}