use strict;
my $str = 'GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 Rank :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BCCH :
GSM NWS\\TOP N Pool 1\\1. TOP N Pool 1 BSIC :
';
my $regex = qr/(\d\.).+\d\s(\w+)\s:/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";