using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+:\h+.*?(?=\h+\S+:)\K\h+";
string substitution = @"\n";
string input = @"Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}