re = /\S+:\h+.*?(?=\h+\S+:)\K\h+/m
str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result