import Foundation
let pattern = #"\S+:\h+.*?(?=\h+\S+:)\K\h+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)