$re = '/\S+:\h+.*?(?=\h+\S+:)\K\h+/m';
$str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;