use strict;
my $str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555"';
my $regex = qr/\S+:\h+.*?(?=\h+\S+:)\K\h+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";