import re
regex = re.compile(r"\S+:\h+.*?(?=\h+\S+:)\K\h+", flags=re.MULTILINE)
test_str = ("Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook\n"
"Action: This Example BB: Bla bla Request: 555\"")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)