const regex = /\S+:\h+.*?(?=\h+\S+:)\K\h+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+:\\h+.*?(?=\\h+\\S+:)\\K\\h+', 'gm')
const str = `Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555"`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);