#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)" & @CRLF & _
"" & @CRLF & _
"(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b"
Local $sString = "Do you like silly hats?" & @CRLF & _
"" & @CRLF & _
"Does this match?" & @CRLF & _
"" & @CRLF & _
"Should we match?" & @CRLF & _
"" & @CRLF & _
"Could we match?" & @CRLF & _
"" & @CRLF & _
"Would it be nice?" & @CRLF & _
"" & @CRLF & _
"Wouldn't it be nice?" & @CRLF & _
"" & @CRLF & _
"Don't match:" & @CRLF & _
"Donuts" & @CRLF & _
"Cannonball Run" & @CRLF & _
"Area 51" & @CRLF & _
"Didley squat" & @CRLF & _
"Williamsburg" & @CRLF & _
"Istanbul" & @CRLF & _
"Haskell" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")