# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\n\n"
r"(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b")
test_str = ("Do you like silly hats?\n\n"
"Does this match?\n\n"
"Should we match?\n\n"
"Could we match?\n\n"
"Would it be nice?\n\n"
"Wouldn't it be nice?\n\n"
"Don't match:\n"
"Donuts\n"
"Cannonball Run\n"
"Area 51\n"
"Didley squat\n"
"Williamsburg\n"
"Istanbul\n"
"Haskell\n\n\n\n\n\n"
"(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.