re = /
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b/im
str = 'Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn\'t it be nice?
Don\'t match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end