use strict;
my $str = 'Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn\'t it be nice?
Don\'t match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)';
my $regex = qr/
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}