import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n\n"
+ "(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\\b";
final String string = "Do you like silly hats?\n\n"
+ "Does this match?\n\n"
+ "Should we match?\n\n"
+ "Could we match?\n\n"
+ "Would it be nice?\n\n"
+ "Wouldn't it be nice?\n\n"
+ "Don't match:\n"
+ "Donuts\n"
+ "Cannonball Run\n"
+ "Area 51\n"
+ "Didley squat\n"
+ "Williamsburg\n"
+ "Istanbul\n"
+ "Haskell\n\n\n\n\n\n"
+ "(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}