package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b`)
var str = `Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn't it be nice?
Don't match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}