# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -/$2 $1 & $4 $1 -/gms;t' <<< "Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
"