import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -";
final String string = "Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub\n"
+ "Abbie, Taylor - Denn niemand wird dir glauben.epub\n"
+ "Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub\n"
+ "Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub \n";
final String subst = "$2 $1 & $4 $1 -";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}