const regex = /^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -', 'gms')
const str = `Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
`;
const subst = `$2 $1 & $4 $1 -`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);