$re = '/^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -/ms';
$str = 'Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
';
$subst = "$2 $1 & $4 $1 -";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;