# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -"
test_str = ("Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub\n"
"Abbie, Taylor - Denn niemand wird dir glauben.epub\n"
"Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub\n"
"Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub \n")
subst = "$2 $1 & $4 $1 -"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.