#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -"
Local $sString = "Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub" & @CRLF & _
"Abbie, Taylor - Denn niemand wird dir glauben.epub" & @CRLF & _
"Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub" & @CRLF & _
"Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub " & @CRLF & _
""
Local $sSubst = "$2 $1 & $4 $1 -"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)