// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -").unwrap();
let string = "Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
";
let substitution = "$2 $1 & $4 $1 -";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}