re = /^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -/m
str = 'Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
'
subst = '$2 $1 & $4 $1 -'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result