using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -";
string substitution = @"$2 $1 & $4 $1 -";
string input = @"Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}