import Foundation
let pattern = #"^([^,]+?), ([^-&]+?) & ([^,]+?), ([^-]+) -"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Aaranovitch, Ben - Peter Grant 01 - Die Fluesse von London.epub
Abbie, Taylor - Denn niemand wird dir glauben.epub
Aiken, G. A. - Drachenwandler 01 - Dragon Kiss, Drachen Kuss.epub
Achilles, Achim & Joung, Frank - Laufen und Trainieren.epub
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1 & $4 $1 -"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)