# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,[^,]*,/$0\n/g;t' <<< "Model1,Model2,Model3,Model4,Model5,Model6,Model7,Model8,Model9,Model10"