use strict;
my $str = 'Model1,Model2,Model3,Model4,Model5,Model6,Model7,Model8,Model9,Model10';
my $regex = qr/,[^,]*,/p;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";