import re
regex = re.compile(r",[^,]*,")
test_str = "Model1,Model2,Model3,Model4,Model5,Model6,Model7,Model8,Model9,Model10"
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)