// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r",[^,]*,").unwrap();
let string = "Model1,Model2,Model3,Model4,Model5,Model6,Model7,Model8,Model9,Model10";
let substitution = "$0\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}