using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=";
string substitution = @"$1 $2 =";
string input = @"
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}