use strict;
my $str = '
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x';
my $regex = qr/Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=/mp;
my $subst = '$1 $2 =';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";